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ABSTRACT
The SAS/AF development tool source control manager (SCM) is a source file management
facility featuring SAS file check-out/check-in capability. This feature allows several developers to
have edit access to the same files, while ensuring that no one makes changes to a program while
another developer is making changes to the same program. It is designed to be used with
SAS/SHARE®.
The Standard Economic Processing System (StEPS), a batch and SAS/AF system developed by
the U.S. Census Bureau for processing data from its economic surveys, is a prime candidate for
SCM. It is maintained by several developers requiring edit access to its files. This paper
describes how SCM has been implemented for StEPS, providing a basis for how it can be used
by other organizations.

INTRODUCTION
The source control manager is an application providing source file management for applications
development using SAS/AF. Its features include a convenient GUI interface, SAS file checkout/check-in capabilities, and revision control. It allows a team of software developers accessing
the same catalog entries, to update files using a check-out/check-in procedure. This prevents
individual users from attempting updates at the same time. The application is designed to be
used with SAS/SHARE. In maintaining StEPS code we have experienced instances when
“almost” simultaneous updates result in loss of intermediate versions of program code. These
occurrences motivated the implementation of SCM in our system. Although SAS/SHARE provides
a message when update is attempted while another user is accessing a file, this was insufficient
for our development needs.
An important feature of SCM is revision control. This refers to the creation of a backup for each
file after check-in. The concept of backup is very important in any file system, and StEPS had
developed a custom macro (%saveold) for our catalog entry backup prior to introducing SCM.
However, the use of this macro is manual, and would not provide a complete record of code
updates (if two users happen to be updating the same program at nearly the same time).
In the following sections, we give a brief overview of StEPS, as it relates to SCM, and describe
installation and usage of SCM based on our experience with it in StEPS. For installation, we
referred to the SAS System Help documentation on SCM installation, while creating our own sets
of instructions as these related to StEPS. These sets of instructions are available upon request,
from the author.

StEPS
StEPS is a generalized system developed in the Economic Directorate of the U.S. Census
Bureau, to process the data from over 100 current economic surveys. As mentioned above, it is
a batch and SAS/AF system. We introduced SCM on our development machine, for source file
management of the catalog entries of the system, for which SCM is designed. Although StEPS
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uses many libraries for the data it processes, most of its program code is contained in the library
PROGRAMS. This library contains the catalogs just mentioned. The main interactive SAS/AF
screen for StEPS is shown in Figure 1 below.

Figure 1

Maintenance of the system is performed by a team of developers in a branch dedicated to StEPS
development, along with several other branches of developers devoted to surveys whose data
StEPS processes. Attempts at simultaneous access to the many catalog files in StEPS by these
developers sometimes causes unintended code overwrites, making StEPS an ideal candidate for
SCM.

INSTALLING SCM (an example using StEPS)
The installation of SCM described in this section is from an administrator viewpoint. It assumes a
SAS/SHARE server for SCM is running. The main parts of installation are:
•
•
•
•
•

SCM directory setup
Invoking SAS
SCM Administration Wizard
Setting up user ID
Registering Program Files

SCM DIRECTORY SETUP
The first step of SCM installation is to create a directory in which the SCM control database
(CDB) will reside. The CDB is a set of SAS data sets containing information about our usage of
SCM. Some of the data set information is used for some of the SCM operations. For example,
ARCHIVES contains the names of previous versions of programs we make updates to, and is
used by the application if we are reverting to a previous version of a program. The HISTORY
data set provides the information we enter as we check a program back into the application,
giving details on the update we made to the program.
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We assume here that we are using SCM with a UNIX® operating system, so we create the
directory as follows, assuming we are starting in the directory, /steps:
mkdir scm
cd scm
mkdir cdb
INVOKING SAS®
In StEPS, we work in an xwindows environment, usually invoking SAS from a common menu,
using a common autoexec file which creates many of the LIBNAMEs required by StEPS.
(Invoking SAS can also be done by typing whatever command your system administrator has set
up for your organization.) After invoking SAS, the next steps in preliminary installation of SCM
are:
•
•
•

Clear the LIBNAME for the directory containing catalogs of interest (in our case, the
PROGRAMS libname): libname programs clear;
Assign the LIBNAME ‘SCMCDB’ for the library containing the SCM control database:
libname scmcdb ‘/steps/scm/cdb’ server=steps’; (Note that we assume we are using
a library on a SAS/SHARE server for our CDB.)
Invoke SCM (by typing ‘scm’) either on the program editor command line, or in the
Toolbox: Explorer Window. This gives us the SCM – Initial Allocation Window,
shown in Figure 2 below:

Figure 2
SCM ADMINISTRATION WIZARD
The SCM administration wizard, as with installation wizards in general, easily guides the user
through the steps of creating a new control database. While going through the wizard, the user
specifies three important things:
•
•
•

The library where the control database will be located.
How many revisions will be stored.
Data sets where user preferences will be stored in SASUSER.

The user clicks on the “Administration…” button in Figure 2 above, to get the administration
wizard started. Due to lack of space, the screens of the administration wizard corresponding to
the above properties are not shown here, but can be seen in the sets of instructions we
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developed, referred to in the introduction. After we go through the administration wizard, we have
created a new, empty SCM database.
SETTING UP USER ID
After setting up the new SCM database, we need to set up a user ID, before proceeding to the
next step. This must be done so SCM will recognize us when we enter the application. To set up
the user ID, we go back into SCM as we had originally done, described in the Invoking SAS
section above, by typing ‘scm’ on the program editor command line or in the Toolbox: Explorer
Window. Then we get the SCM – Initial Allocation Window again (Figure 2 above).

In the “SCM – Initial Allocation” window click the
button and a “Select a Library” window
appears. In the “Select a Library” window, select the “Scmcdb” library, and the following window
appears:

Figure 3
Type in a user ID in the “User ID:” field and press the “OK” button. The “Team Libraries:” window
appears (shown below).

Figure 4a
REGISTERING PROGRAM FILES
In order to be able to use SCM to update program files, we must register our program files in
SCM. This consists of a few simple steps:
•
•
•

Assigning the StEPS PROGRAMS library to the SAS/SHARE server: libname programs
/steps/programs’ server=steps;
Specifying the location of the team library and archive location under the Tools menu in
the Team Library Window.
After registering the program files, we get an updated Team Libraries Window, as shown
in Figure 4b below:

4

Figure 4b

USING SCM (from a developer perspective)
Developer usage of SCM described here is divided into two parts: one time setup, and normal
use.
ONE TIME SETUP
Developers are given a simple set of instructions for creating their user ID, and setting up initial
directory mappings and file options.
Setting up User ID
Invoking SAS the first time after the administrator has installed SCM, they get the SCM – Set
User ID screen shown above in Figure 3. After they type in an assigned user ID, and click the
“OK” button, SCM registers them as SCM users, and creates SASUSER files referred to above,
in the SCM Administration Wizard section.
The Team Libraries Window appears, showing the programs library (Figure 4b). The developer
can expand the library to show the catalogs it contains, by clicking the ‘+’ on the left. Doing so,
they get the following screen:

Figure 5
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Setting up the Local Window
The developer next needs to setup the Local Window. The Local Window is where local
programs reside. Two operations have to be accomplished for the Local Window: library
mapping, and optionally, local file deletion after check in, to preserve space in the developers
local area.
Library Mapping: By clicking on Tools>Options in the Team Window, and SCM – Options Window
appear, with several tabs, including ‘Library Mappings’. In the ‘Library Mappings’ tab, the user
specifies the local directory files should be checked out to.
Local File Deletion after Check in: By clicking on the ‘Options’ tab in the SCM – Options Window,
the user can click on a radio box to indicate that local files should be deleted after the check in
command.
NORMAL USE
Developers are given a set of instructions for:
•
•
•

Development in sessions where updating is not done.
Checking programs out and in.
Creating and registering catalogs and entries.

Development in sessions where updating is not done
These instructions are specific to StEPS, and not part of the SCM documentation. There has
been concern in StEPS that, since SCM requires the programs library to be read/write,
developers might unintentionally overwrite existing programs. In the past this library has been
read only. Developers would only change the protection at the time they copy their programs into
it.
To prevent unintentional overwrites, developers are instructed to exit from SCM after entering
SAS, by clicking on File>Close in the Team Libraries Window. This de-assigns the programs
library. They then submit the following line of code from the Program Editor Window of the SAS
session:
libname programs “&programs” server=&stpserv access=readonly;
Figure 6
Checking programs out and in
As mentioned above, one of the main premises of SCM is the prevention of simultaneous
updates to programs by different developers at the same time. In order to accomplish this, the
developer checks out a program the Local Window to do updates, and then checks it back in to
the Team Libraries window when finished updating. During this process, the developer is locking
and copying the SAS/AF entry or catalog from the Team, to the Local Window.
Checking out a program
After selecting a file, by clicking on it to highlight it, the user clicks on Actions>Check Out in the
Team Window, to check the file out to the Local Window. Alternatively, the “Check Out” icon
(arrow pointing down) in the Toolbox: Explorer window can be clicked to check the file out. The
file will then appear in the Local Window if the user brings that window up.
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After the file has been checked out, a blue padlock icon will appear to the left of it in the Team
and Local Windows for the user who has the file checked out. Other users will see a gray
padlock icon in front of the file in the Team Window on their screens. The Team Window with a
file locked is shown in the following:

Figure 7
Checking in a program
After finishing updates, the user checks the program back into the Team Library Window by
clicking on Actions>Check In in the Local Window. As with check out, alternatively, the “Check
In” icon (arrow pointing up) in the Toolbox: Explorer window can be clicked to check the file in.
After check in, the user is forced to enter a change description in the “SCM – Change
Description” window as shown:

Figure 8
The information entered into this screen is put into the HISTORY data set in the library containing
the SCM control database.
Creating and registering catalogs/entries in the Team/Local Windows
The developer may have a need to create a new catalog and entries, or new entries for an
existing catalog. In either case, the user first goes to the Local Window, and Edit>New… on the
menu. This gives the following screen, with the new catalog and entry shown. The user clicks on
‘Create.’
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Figure 9
For a new frame and scl entry, the familiar frame entry displays. The frame and corresponding
scl entry are edited as usual. After saving the new entries, the user gets a message that the file
already exists in the Create New Entry or Member window above. Ignore this, and Click the
‘Done’ button. Finally, compile the frame in the Local Window as usual, by going to
Tools>Compile.
Next, you must copy the new catalog and entries to the SCM Team Window. In the Local
Window, making sure the new catalog is highlighted, got the Actions>Copy To… on the menu.
The SCM – Copy Selection(s) window comes up, as shown below. Specify the new catalog,
along with library as shown, and click ‘OK.’

Figure 10
Registering new catalogs in the Team Window
Before the new catalog will show up in the Team Window, it must be registered in SCM. This is
accomplished by going to Tools>Administration Utilities>Source Data. After entering the
information shown below, click the ‘Register’ button. When registration is complete the screen
will appear as shown below. Click ‘OK.’
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Figure 11
Back in the Team Window, click View>Refresh to get the new catalog to show up in the
PROGRAMS library.
Creating new entries in existing catalogs in the Team Window
This process is similar to the above one. After the entry is created in the Local Window, the user
copies the entries to the Team Window, as shown using the screen in Figure 10 above. Back in
the Team Window, the user must register the new entries, before they will show up. From the
menu, go to Tools>Administration Utilities>Source Data, as before to get the following screen.
Information is entered as shown:

Figure 12
Click ‘Synchronize…’ to finish the operation, since you now want to ‘synchronize’ entries in an
existing catalog. This is the equivalent of registering. You enter the ‘Synchronize Source Files’
screen. You arrive under the ‘Registered but don’t Exist’ Tab (on the left). Click the ‘Exists but
no Registered’ Tab on the right, to get the screen shown. The entries to be synchronized are
highlighted as in the first figure. Click the ‘Register’ button towards the lower right. After
registering, we see the second screen shown.

9

Figure 13a

Figure 13b
After clicking ‘OK’ on the screen in Figure 13b, we are brought back to the Administrative
Functions screen (Figure 12 above). When we get back to the Team Window, we can click
View>Refresh to have the new entries in this existing catalog appear.

CONCLUSION
The SAS/AF development tool source control manager provides a means for preventing
simultaneous edit access by multiple developers, while maintaining programs in a team
environment. This facility also maintains previous versions of programs. In this paper, we have
described installation of SCM, as well as file check out and check in, practices which can be
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added to prevent unintended file overwrites, and creating and registering catalogs and entries.
Other features not covered here include locking and unlocking files, and reverting to previous
versions of a program. Details on these are available from the author, on request.

REFERENCES
SAS Institute Inc. (2001), SAS System Help, Release 8.02, Cary, NC: SAS Institute Inc.
Tasky, D., et al. (1999). “Get In Step With StEPS: Standard Economic Processing System,”
Proceedings of the Twelfth Annual NorthEast SAS Users Group Conference, 167-175.

ACKNOWLEDGMENTS
SAS, SAS/AF and SAS/SHARE are registered trademarks or trademarks of the SAS Institute Inc.
in the USA and other countries. ® indicates USA registration.
Other brands and product names are registered trademarks or trademarks of their respective
companies.

CONTACT INFORMATION
Your comments and questions are valued and encouraged. Contact the author at:
Larry Altmayer
U.S. Census Bureau
ESMPD, Room 1223-4, MS 6200
Washington, DC 20233-6200
(301) 763-2569
lawrence.w.altmayer@census.gov

11

