ABSTRACT

JMP® software, when used as a stand-alone package, provides a variety of ways of understanding, visualizing and communicating what your data is telling you. Adding JMP software and functionality to a SAS® programming environment can result in the best of both worlds. Topics covered include previewing SAS data, running SAS procedures from JMP, using JMP for further exploration of SAS results, and using SAS geographic data with JMP. Through these features and others in JMP's point-and-click environment, JMP extends the power and functionality of SAS.

Examples used in this paper were created with JMP 8 and SAS 9.2 that coexist on a Windows 2008 R2 Enterprise Server. The techniques represented are not platform-specific and can be adapted by beginning through advanced SAS and JMP users.

INTRODUCTION

JMP was developed by John Sall and others at SAS Institute in the late 1980s as an interactive statistical visualization and discovery tool. While no longer an acronym, the JMP name came from "John’s Macintosh Project.” According to Sall, the JMP name also conveys “the idea of a lively product that jumped responsively to the user’s wishes.” JMP Version 1 shipped on October 5, 1989 as a Macintosh desktop product with a graphical user interface. JMP found its customer base among scientists and engineers and therefore originally focused on improvement in three areas: 1) design of experiments (DOE), quality and productivity support (Six Sigma), and reliability modeling. JMP was later released for Microsoft Windows (v. 3.1) in 1993. JMP includes support for both 32- and 64-bit systems.

Until recently SAS users and JMP users were considered to be mutually exclusive members of the greater data and analytic community. Increasingly, the advantage of using JMP as a complement to SAS is resonating in the SAS community. To this end, SAS has held "JMP for SAS Users" days. And JMP papers and sections are part of SAS user's conferences and meetings. While SAS is still my major tool of analysis, like many other SAS users, I now find myself using JMP in conjunction with SAS.

JMP is not SAS-mini. It is a visual discovery tool that can reside on a desktop or server. Through point-and-clicks, statisticians and data analysts from all industries can visually look at relationships in their data. The suite of visual tools and graphs allow not only exploration but output display without SAS graphics code. JMP is used for data exploration and display, experiment design, quality control, qualitative analysis, statistical modeling and report building.

DIFFERENCES BETWEEN JMP AND SAS

While JMP and SAS are both great tools for data exploration and analysis there are several differences between the two. One of the most basic differences between JMP and SAS is in ease of use. Additionally, it costs less, is easier to install, takes up less disk space and requires less RAM and other computer resources to run. JMP is limited in data handling, programmability and statistical depth. It cannot process the millions of records that SAS supports. It does not support multiple programming languages.

Other differences:
- Product robustness – JMP does not do everything but what JMP does it does well.
- Language – JMP Scripting Language (JSL) is NOT SAS code.
- Data formats – JMP cannot read binary and other specialized formats.
- Data tables – JMP data tables are not spreadsheets- properties are applied to columns not individual cells
- Variable names
  - JMP variable names can include spaces, most characters, and can start with numerals
  - For SAS data sets, JMP uses variable labels as variable names
- Missing Values – not considered lower than lowest numeric value in JMP.
- Modeling type – JMP assigns a modeling type of continuous, ordinal or nominal for analysis context.
Statistical Methods – The table below shows some major differences between analyses in JMP vs. SAS.

<table>
<thead>
<tr>
<th>Statistical Procedures/Methods</th>
<th>SAS</th>
<th>JMP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Random Effects Mixed Model</td>
<td>General Mixed Models</td>
<td>Simple models only</td>
</tr>
<tr>
<td>Proportional Hazard Model</td>
<td>Fits with time-varying covariates and exact methods for ties</td>
<td>Simple approach for ties</td>
</tr>
<tr>
<td>Regression</td>
<td>Provided with regression diagnostics such as leverage plots</td>
<td>Provided</td>
</tr>
<tr>
<td>Nonlinear Regression</td>
<td>Provides three separate nonlinear fitting facility in three products</td>
<td>Provides single nonlinear regression facility</td>
</tr>
<tr>
<td>Spline and surface fitting</td>
<td>Both quintic spline and thin-plate surface fitting and contouring</td>
<td>Simple flat –triangle fitting and contouring</td>
</tr>
<tr>
<td>Multiple comparisons</td>
<td>Over 20 methods</td>
<td>3 methods</td>
</tr>
</tbody>
</table>

Table 1. SAS vs. JMP for Statistical Analysis.

JMP ADVANTAGES

While the relatively low cost, low computer resources, and intuitive interface are all advantages when making a business decision to include JMP in an analytic arsenal, here are some additional advantages provided by JMP.

- JMP provides a solution for those needing a desktop statistics package that is suited for all users. Users can be productive with the software from the time of installment without training classes or learning a programming language.

- Analyses and the resulting output in JMP are interactive, not static. Command options are available interactively to extend an analysis or provide more details. Depending on the options selected, further opportunities appear.

- You don’t have to think ahead and specify everything you want before you launch the analysis.

- Every JMP® analysis has a graph as its central element and most statistical tests have their own graphics.

- Statistical results interpretation - context-sensitive assistance for statistical procedure selection and for interpreting statistical results.

- Interactively subset the data. Users can work with a subset of the selected data set by selecting rows or asking for a random selection as in the window below:
Tip of the Day – JMP proactively tries to help with tips on its use. Here is an example:

JMP/SAS CONNECTIVITY

With the release of JMP 7.0 in 2007, JMP began to provide real connectivity with SAS, making it not only easier for JMP users to discover relationships in SAS data, but also allowing SAS users to begin to harness JMP capabilities. Versions 8 and 9 have added additional features to that connectivity. Using JMP, interactions with SAS include the ability to:

- Connect to SAS on a local machine or remote SAS Server from JMP
- Write or create SAS code in JMP.
- Submit SAS code and view the results in JMP.
- Retrieve and view data sets generated by SAS.
- Use SAS map datasets with JMP.

John Sall and others at SAS Institute developed JMP in the late 1980s as an interactive statistical visualization and discovery tool. In recent years, JMP has broadened its focus to support business visualization in partnership.
with SAS and now JMP developers work with various SAS teams on projects in several areas, collaborating and sharing efforts. Windows is currently the most prevalent operating system for JMP. With much to offer both as a standalone product and as an enhancement product for SAS users, the JMP user community continues to increase around the world.

SETTING UP A CONNECTION WITH SAS

With JMP, users can connect directly to a SAS server and work directly with SAS data sets. The server can either be a SAS metadata server or a SAS workspace server. If the server is a metadata server, the earliest version of SAS supported by JMP connections is SAS 9.1.3. You can only be connected to one metadata server at a time. In addition to metadata servers and workspace servers, JMP will also connect to SAS on your local machine. In the example below, the connection is to a remote SAS workspace server.

To connect to a SAS server, click File > SAS > Server Connections.

The following window will open up. Enter your remote server name or IP address and the port.

![Server Connections Window](image)

Then click on the Connect button at the bottom of the window. The following window then pops-up for the username and password for new workspace SAS server connection that you are establishing. Enter Username and Password and click on the OK button.
This server will then be displayed as the current active connection. Setting up a SAS Metadata server is similar, except that it is necessary to create a profile for the server. The profile includes the machine name or IP address, port, and username/password. If a server is unavailable, or if the connections failed, the server’s name is shown in light, italic text but is available to click to try to re-establish the connection.

After connecting to the server, you can:
- Select a server to see a list of libraries that server contains.
- Select a library to see a list of data sets within that library.
- Select a data set to see a list of columns within that data set.
You can change this data set, library, or server at any time.

If JMP resides on the same server as SAS, you can set up your connection as follows:
READING SAS DATA SETS WITH JMP

There are two methods for reading SAS data sets with JMP. One involves importing from the active SAS server. To import or open a SAS data set residing on the SAS server:
  • Select a SAS data library on the server.
  • From the library display, select a data set.
  • Click Import.

The SAS data set is imported into a JMP data table. When importing, JMP attempts to make the best match to the SAS format. Available options include importing only a subset of the columns of the original SAS data set and selecting a random sample of the data set. (SAS/STAT needs to be licensed and installed on the selected server for random samples.) While many options are available, the default random sample is a 5% sample.

Data sets residing on a server can also be previewed and browsed on the server from JMP without importing into JMP. When you select a data set for preview, the first ten rows and columns in the data are displayed by default.

SAS data sets can also be opened in JMP without connecting to a server (server connection is still required for Macintosh users.) To open a file directly without server connection:

1. Select File > Open.
2. On Windows, select SAS Data Sets from the list next to the File name drop-down, as illustrated below.

3. Select the SAS data set that you want to import.
4. Select the desired JMP column names. You have two options:
   • SAS variable labels, or
   • SAS variable names. (Variable name is selected above.)
5. Indicate whether the data set is password protected. If password-protected is selected, a screen pops open for entry of the dataset password. This window also requires you to select the appropriate type of password: (Read, Alter, or Write) for Windows files.
Another option is the “Select this filter the next time this dialog is invoked” check box. This sets the default file type choice to the type that you select next to the File name list. If selected, the default file type will be **SAS Data Sets** the next time you reach this window.

Click the **Open** button at the bottom of the screen after all selections are made to read the data set into JMP. SAS variable names and formats are preserved and can be saved after changes are made to the SAS data set. For the class data set selected above, here is the data set in JMP.

![Image of JMP window](image-url)

Once the data set is in JMP, all the interactive, exploratory data analysis and modeling tools that come with JMP are available to use with your SAS data set including the full array of experimental design and graphics options. Pull down menus are available for DOE (Design of Experiments), Analysis, and Graph.

In the example below, the bubble chart option was selected from the GRAPH menu. The imported CLASS SAS data set was used as the data source. Height was selected as the Y variable, and Weight as the X variable, with color coding by Sex. The default colors were used for the bubble plot. Other options available included:

- **ID** – identify rows that should be aggregated into a single bubble.
- **Time** – separate bubbles for each time period.
- **Size** – Area of bubbles is proportionate to size value. If left blank, the default bubble size proportionate to the number of rows.
These selections created a graph with very small bubbles. The bubble size was increased to the display size below using the slide bar on the bottom of the graph. This slide bar is an example of the interactivity that is available using SAS data sets (or any data) within JMP.

WRITING AND RUNNING SAS CODE IN JMP

SAS code can be submitted directly from JMP to the currently active SAS server. Any listing output will automatically be retrieved by JMP and displayed in the JMP SAS Output window. The SAS Log is also retrieved by JMP, and, if there are any errors in the submitted code, the SAS Log is automatically displayed in the JMP SAS Log Window.

To run SAS code directly from JMP

- Open an existing SAS program using File > Open, or
- Create a new SAS program. (Create a new SAS program by selecting File > SAS > New SAS Program and
• From the Edit menu, select **Submit to SAS** or
• Right-click in the Program Editor window and select **Submit to SAS**.

The menu item also includes the name of the active SAS server that the SAS code will be submitted to.

Here is the JMP SAS Program Editor window:

![JMP SAS Program Editor](image1)

This is the menu that pops up when right clicking. Select Submit to SAS to run the SAS code in the JMP SAS Program Editor Window. Select **Submit to SAS**.

### GEOGRAPHIC ANALYSIS WITH JMP

SAS/GRAPH includes map data sets that can be converted for use as shape (.shp) files with JMP. These data sets are then part of the JMP Maps library. They come as a pair of data sets just where the traditional map data sets contain the XY coordinate data. Unprojected SAS data sets can be used with JMP only after they’ve been converted to degrees and the longitude variable has been adjusted for projection. The following SAS data sets have already been converted to shape files:

- world countries
- states and counties in the United States
- first-level divisions for Canada, China, the United Kingdom, France, Italy, Japan, and Germany

To map SAS Data in JMP:

1. **Open** the SAS data set with a geographic component (in this case state).
2. **Select** **Graph > Graph Builder**.
3. **Drag and drop** State into the Shape zone.
4. **Drag and drop variable to be mapped into the Color zone.**

The imported SAS data set in the example map below displays infant mortality by state as a continuous variable. In the data set, Alaska, Hawaii, Puerto Rico and the US Virgin Islands have been excluded from the map. Note the Rows excluded and other data information to the side of the data set.
To create the map, the State variable was dragged and dropped into the Shape Zone and the infant mortality variable was dragged and dropped into the Color Zone. Here is the resulting map.

To change colors and transparency for a map, right-click on the color bar in the legend. Continuous variables use a color gradient. To change the color theme:
1. Right-click on the color bar and select **Gradient**.
2. In the Gradient Settings window, select a different Color Theme.

To change the color of one of the variable levels for categorical variables:
1. Right-click on the color of the variable level that you want to change and select **Fill Color**.
2. Select the new color.

To export the map for use in documents and reports, you can copy and paste to a document or you can hover over the top bar for menu to appear and save to a variety of formats, including .jpeg, .gif, and .pdf. JMP provides an easy and accessible means to map your SAS data.
OTHER SAS CONNECTIVITY FEATURES

JMP also lets users add a SAS Stored process to JMP. A SAS metadata server connection is required. Once you are connected, you can select the SAS Stored Process to add to your JMP project.

JMP converts SAS code to JMP Scripting Language or JSL. SAS programs that are written in JMP can be saved either as a SAS program or as JSL. You can also write directly in JSL to access SAS from JMP.

For SAS Enterprise Guide Users, there is an Enterprise Guide task to open a SAS data set in JMP. This allows you to select a data set from your PC and open it in JMP as part of an EG process flow. The task does require that your SAS data set be on your local PC before opening it with JMP.

CONCLUSION

In addition to providing a full array of tools for interactive statistical visualization and discovery, JMP also provides tools that connect with and enhance SAS capabilities. These include the ability to access SAS and SAS data, visualizations using SAS map data sets, running SAS within JMP and other features that will allow users to take the visualization of SAS data to new heights. SAS remains the best choice of software if you need to handle millions of records on a daily basis or want maximum flexibility and robustness in terms of programming and statistical options. For smaller jobs, JMP provides a streamlined alternative without sacrificing the quality and validity of the output and includes all of the most popular types of analysis with the added bonus of interactivity. As the JMP 8 Statistics and Graphics Guide explains: “When you are looking for an information delivery vehicle, sometimes you need a truck that can haul anything, every day, like SAS. But if you are out for a drive to go exploring, you might find it best to drive a small car, or even a sports car like JMP. Perhaps both belong in your garage, so you can use the one that best suits the immediate task.”

REFERENCES


ACKNOWLEDGMENTS

Thanks go to Community Care Networks of Virginia, especially Andrew Baker, for access to the JMP product used in this paper.
CONTACT INFORMATION
Your comments and questions are valued and encouraged. Contact the author at:
Barbara B. Okerson, Ph.D.
Senior Health Information Consultant
West Region Client Reporting & Analytics
WellPoint Health Care Analytics
Phone: 804-662-5287
Email: barbara.okerson@wellpoint.com

SAS, JMP, and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.