Get Your "Fast Pass" to Building Business Intelligence with SAS® and Google Analytics

Tricia Aanderud, And Data, Inc, Raleigh, NC
Angela Hall, SAS Institute, Inc, Cary, NC

ABSTRACT

See the magic of Google Analytics with SAS® Business Intelligence tools! Use your "Fast Pass" to learn SAS® Information Map Studio, SAS® Web Report Studio, and SAS® Information Delivery Portal with the authors of the newly released "Building Business Intelligence with SAS®". We will guide you step-by-step through creation of information maps, custom web reports, and portal pages using data from Google Analytics. You will learn some tips and tricks for creating custom data items, designing and linking reports, and adding external content to your portal.

INTRODUCTION

Google Analytics provides extensive data about how users interact with your website. After finishing our book, Building Business Intelligence with SAS: Content Development Examples, we started a companion website, Business Intelligence Notes (www.bi-notes.com), to publicize the book and provide users with more examples, tips, and tricks.

After creating the website, of course, we were curious about visitors to the site, segments attracting the most visitors, and the topics that attracted the most attention. Naturally, the first thought was to import that data into the SAS Business Intelligence (BI) tool. Using that data, today we will demonstrate how we handled the data using Information Map Studio, Web Report Studio, and Information Delivery Portal. You will learn more about the Google Analytics and some of the other SAS BI clients along the way.

GETTING THE GOOGLE ANALYTICS DATA

To get the website traffic data, we used a third-party tool called Excellent Analytics Add-In to export the data from Google Analytics site into Microsoft Excel. There are some limits as to how much data you can extract at once, however the main information we wanted was available. [Check out the http://www.bi-notes.com site for details about this data.] We extracted three main tables: Visitors, Landing Page, and Keywords.

Each table focuses on a different part of the blog:

- GA_VISITORS contains counts for traffic, how visitors found the site
- GA_LAND_PAGE shows which page the visitor “landed” on when they came to the site
- GA_KEYWORDS contains the search terms the visitor entered in Google to find the site.

Using SAS Enterprise Guide, the data was imported from MS Excel into a SAS data set. The data sets lacked a common variable that we could use to join the table. Using a SAS macro, our code combined several variables in each data set to create a JOIN_KEY variable. When creating the information map, we will use this variable, called Join_Key, to join the tables.

The JOIN_KEY variables did not make much sense for the GA_Keywords table, so we elected to use that data in a different way. The three data sets were registered in a metadata library called GA_DATA.

Figure 1 shows how one of the data tables looked after they were converted from Microsoft Excel. To better categorize the data, we converted the Source variable to one called Segment. In addition, the Page variable was used to create the Topic variable.
Building Business Intelligence with SAS® and Google Analytics, continued

USING SAS INFORMATION MAP STUDIO

Of course, data tables hold valuable information for the business but for general users the required understanding of data table relationships, cryptic variable names and complex formats can hinder the process of analyzing and generating value from the data. Information maps provide a business layer definition that report authors can understand easily. Key benefits of using information maps include:

- Customized labels and descriptions
- Central location for calculations and filters
- Query and data storage information remains transparent to report authors

Typically, data administrators create information maps because they have a better understanding of the data table structures and the common reporting requirements. You can use information maps in all of the SAS BI clients.

WORKING WITH YOUR DATA

Planning the information map may be the most difficult step. You could create a single information map for each web report, but we recommend that you create information maps for each subject (main data source) area. For instance, if you create an information map for your warranty claims data that can accomplish 50-70% of the reporting needs, then you will significantly reduce the work required when there is a change to the claims data source.

Here are few other things to keep in mind as you start:

- What data items do I need create?
  For this information map, we want to group the categories by date values. We have a date, so we can make Year, Month, Week, and even weekday.
- What custom measurements do I need to create?
  For our purposes, we need to create some percentages, such as Bounce Rate, Success Rate, New Visitors, and so on.
- What filters and prompts are common?
  Since we have the date variations, we created filters and prompts for Year, Month, and Week. The chief categories, Segments and Topics, also seemed to be reasonable filters.
- Any additional security requirements?
  You can set up identify filters to control how the map is viewed; otherwise simply save the map in a metadata folder accessible only by the applicable group

CREATING AN INFORMATION MAP

After opening and logging into SAS Information Map Studio, you can start building your information map. From the Resources-Application Servers tab, you can locate data tables, OLAP cubes, and stored processes to add to your information map.

In Figure 2, the GA_LAND_PAGE and GA_VISITORS data sets are used as the source.
1) In the Resources – Application Servers tab, navigate to the library where the data is stored. Drag the tables you want to the Selected Resources tab, as shown in Figure 2. Expand the tables so you can see the data items (or variables).

2) Drag the data items you want in the information map to the Information Map Contents tab, as shown in Figure 2. You only need to select the data items you want in the information map.

---

To organize your data items better, right-click the information map name (GA_BLOG_DATA after it is saved) and select Add Folders from pop-up. You can then name the new folder whatever makes sense for the data. In Figure 2, four folders help organize the data: Visitors, Content, Measures, and Date.

**ESTABLISHING RELATIONSHIPS**

If you have more than one table, the SAS Information Map Studio attempts to join the tables based on a common key. For a simple join, such as the one in our example, the application usually makes the correct guess. However, you can modify the join from the Relationships tab if needed.

**WORKING WITH THE DATA ITEMS**

You can add, modify, or delete data items. Let’s go through some examples.

**RENAMEING A DATA ITEM**

To rename a data item, from the Information Map Contents tab, right-click the data item and select Rename from the pop-up menu. Type the new variable name in the highlighted area. In Figure 3, Pageviews is renamed to PageViews. We could have used any name except for a name that was already being used. Therefore, we could not have named it Time On Site or Bounces.

You can use the pop-up menu to perform other actions on the data item. For instance, you can copy the data item and use it as the basis for a new data item.
CHANGING THE CLASSIFICATION: CATEGORY VERSUS MEASURE

In the Selected Resources tab, the data items have different icons next to the name. The icons indicate if the data item is a number (blue circle with numbers), a character (red triangle with A), or a date (calendar) variable.

When the variables are moved to the Information Map Contents area – they can be a Category (yellow index cards) or a Measure (ruler). Data items representing character values can be grouped into categories, such as Topic, Page, or Source. Measures are how the data is counted. You would count the number of visits to each topic, average the time spent on the site, and so on. By default, SAS Information Map Studio makes all character values into Categories and all numeric values into Measures.

If you want to change the data classification, click the data item to select it. In the Properties area, click Classification and select Category or Measure, as shown in Figure 4.

![Figure 4 Changing Classifications](image)

The Properties tab profiles each data item. You can make additional changes to data item from here also.

CREATING CUSTOM MEASUREMENTS

You can create custom measurements in the information map. For instance, let’s create a data item that calculates our conversation rate (the number of visitors who asked for more information about the book). Use the same steps as above to create the new data item, but make these changes:

1. Create a new data item by right-clicking the Measures folder and selecting New Data Item. The Data Item Properties window appears.
2. In the Data item name field, provide a name for the data item. Then click the Edit button to create a formula for the data item. The Expressions Editor window appears.
3. In the Expression Editor, create the calculation. This is the Goal 1 Completions divided by Visitors. Click OK to return to the Data Items Properties window.
4. From the Classifications, Aggregations, Formats tab, select PERCENT as the Format type. This causes the data item to appear with the percent sign.

You can use a variety of SAS functions to create a data items, such as SUM. The Functions tab lists the many functions available and provides guidance on how to set up the expression.
Creating Custom Calculations

It's a good idea to centralize as many filters and prompts as you can. What you do not want to happen is for every report builder to create the same filters and prompts. It is duplicated effort and if something changes, then everyone has to update multiple reports. With some planning, you can pre-determine what filters and prompts are needed.

Filters can also be defined for general use (called pre-filters) so each time the information map is queried from a report, data will automatically be filtered. This ultimately reduces the amount of summary tables built off the same source table. For instance, you could create a pre-filter that only pulls in the last 6 months of data.

Note that prompts can be created from SAS Management Console and shared between multiple information maps. This is covered in more detail in the Prompting Framework chapter of our book.

Adding a Filter

Users might filter on date values; you can set up a filter for the Month data item. This causes the information map to select records from the past 6 months automatically. As we start this information map, there is only about four months of data. When there is more data, we may only want to see certain time periods to keep the reports manageable. To add a filter, do the following:
1. In the Information Map Contents area, right-click a folder name and select New Filter from the pop-up menu.

2. In the Filter name field, type the name.

3. Add some text to describe the data item in the Description field.

4. In the Data Item field, select the data item that should be filtered. In this case, it’s the Month data item.

5. Add the filter condition in the Value(s) area. For this example, the filter should only show records from the past six months.

6. If you do not want the user to see the filter, select this checkbox.

   If you select the Hide from user check box, then you need to add this filter as a Prefilter to the information map. Go to Edit > Properties > <information map name> and add the filter as pre-filter to the table. Consult the online help for more details.

**Figure 6. Adding a Filter**

**ADDING A PROMPT**

A prompt is a way to ask the user a question. For example, “Which region do you want to see” or “Which months do you want to use”. These questions, or prompts, are asked before a report is generated or data query is created. You can create prompts to accept text strings, numbers (with range validation), single or multiple values from a predefined list of values, date or date-time values, and even variable names for use within SAS task roles.

You can add a prompt to allow the user to select the desired values.

1. Create a new filter called Segment using the instructions in Adding a New Filter. In the Value(s) area, select Prompt user for value(s) choice. Then select the New button.

2. In the New Prompt window, complete the Name and Displayed text fields.

3. From the Prompt Type and Values tab, create how the prompt will work.

   a) In the Prompt type field, select the prompt. The prompt defaults to the type of your data item.
   
   b) You can choose how you want the prompt populated. For this example, select User selects from a dynamic list. This causes the information map to generate values based on the data item contents.
   
   c) In Number of values drop-down, select Multiple values. This allows the users to select more than one value.
   
   d) In Data source, select Use the current information map as the source.
   
   e) In the Data item drop-down, select Segment.
Figure 7. Adding a Prompt

Prompts can be cascading or dependent on one another. Prompts can also include (but are not limited to) open text boxes, drop down boxes, calendar widgets (for date selection), or color widgets (for customizing displays. The prompt example above is only one of many available in the prompting framework; therefore, we covered the topic in its own chapter.

TESTING THE INFORMATION MAP

After making the changes, you need to review the information map to ensure the changes worked as desired. Select Tools > Run Test Query to see the Test the Information Map window.

1) Select the items you want to see by moving the data item from Available items to Selected Items.

2) Click the Run Test button. Because the SegmentFilter is part of the test query; then select one or more segments from the Prompt Value Specification window. This works the same way the user will interact with it. Make a few selections and then click OK.

The Results should reflect the selections you made for the prompt. Else the prompt is not working.

Figure 8 Testing Changes
BUILDING REPORTS WITH SAS WEB REPORT STUDIO

Web Report Studio is a reporting tool; however your organization will find this is a data access tool with broad appeal. Usually, querying data is relegated to programmers or analysts because this group has advanced experience with programming tools such as BASE SAS and SQL. While Web Report Studio does not have the same level of flexibility and functionality as some other SAS tools, it can act as a data access tool, allowing anyone to quickly query data and analyze results. The allure expands to anyone interested in making a decision based on data.

SAS Web Report Studio has two modes: Edit and View. In the **View** mode, you can see the report as an end user sees it. In the **Edit** mode, you design the report.

**Figure 9 SAS Web Report Studio Overview**

**DESIGNING A REPORT**

*The Blogsite Statistics – Summary Report* contains four charts based on the data from the GA_BLOG_DATA information map created in the last section. For this example, we will start the report and build the first table. The graphs are very similar so once you can build one – you can build them all.

It is easier if you design your report before you start. Our reports started with the questions we had about the data. For instance, here are some of the questions we had:

- How many people are visiting the site each week? What percentage of those visitors are new?
- Is there a particular day of the week that generates more traffic? Does it change over time?
- Which segment produces the most traffic to the site?
- What is our conversation rate? How many people are interested in the book each week?

**Figure 10 Web Report Studio Summary Report**
We also had some specific questions about what happened each week. We created a second report called *Blogsite Statistics – Detailed Weekly Report* that answered these questions, which were answered in a detailed report.

- What topics got the most attention?
- Which weekday was the most popular?
- Which landing pages kept people interested and resulted in a conversion?

![Weekly Detailed Report]

**Figure 11 Web Report Studio Detailed Report**

**ADDING YOUR INFORMATION MAP**

To start a new report, you need data. After starting SAS Web Report Studio, select File > New to start a new report. Then find your data.

1) From the Edit tab, click **Data > Select Data**.

2) When the Data window appears, click the **Select Data Source** button. This will allow you to navigate to where your data is stored. Select your information map and select Ok.

3) Your information map shows all the data items available. Place the data items you want to work with in the Select data items tab. Click Ok to return to the Edit tab.

![Select Data]

**Figure 12 Getting the Data**
ADDING A GRAPH

After adding the data, you can include charts or tables in the report to improve usability of the report. The work area is divided into smaller parts and each part holds one object. Use the toolbar down the left side to control the work area. You can add rows, columns or control the object alignment. This allows you to have a more customized report.

Along the top of the work area there is a row of icons. Each object represents a different graph or chart type. You can also add text, images, or stored processes. To add an object to the report, drag and drop an object icon in the work area.

![Figure 13 Adding a Graph](image)

CUSTOMIZING YOUR CHART

When you add an object like a chart, Web Report Studio places all data items into the object by default. Click the View tab to see the default choices. In some cases, the default choices may create the chart you always dreamed possible! If the chart is not as desired, you can change it by right-clicking the object and selecting Assign Data.

In the Assign Data Items, you can re-arrange the data items around and assign to the categories that best fit. When you first start, you may have to try this step several times before the chart speaks to you. In this case, we wanted to see the monthly trends. For each Month (Category), we wanted to show how many visits (Bar Height) to the site along with what percentage (Line Height) of those visitors were new.

![Figure 14 Customizing and Object](image)
MAKING IT LOOK NICE

Using the Properties window, you can further customize the chart. For the chart in Figure 14, there were a few changes made to improve the overall appearance.

1) Right-click the chart and select Properties from the pop-up menu. The Properties window allows you to control the charts overall appearance.

2) In the General tab, from the Title area, type the chart name. You can also change the font face, type, size, and alignment.

3) In the Graph Size area, click Fixed Size so you can control the size of the chart.

4) In the Axis tab, you can control the appearance of Axis. Click the Fixed radio button to set the axis values. For instance, the right axis is set to a Maximum value to 1 so it goes to 100%.

5) In the Labels area, you can change the axis label appearance and orientation. For instance, change the axis labels to be vertically aligned.

6) In the Legend tab, change where the legend is placed.

Figure 15 Working with Properties
TIPS & TRICKS: LINKING A DETAILED REPORT

The Blogsite Statistics Summary Report can then link into a detailed report, allowing us to delve immediately into the cause of this or that. The Weekly Detailed Report contains specific statistics about what happened during the specific week. We are going to edit this report to add some information.

![Image of Linking Reports](image1.png)

**Figure 16 Linking Reports**

**SETTING UP THE DETAILED REPORT**

The detailed report is set up so that the Section has a filter applied. A section filter uses a data item to filter all objects in the report. To set up a section filter, go to the Edit Tab and do this:

1) If there is more than one section, select the section you want to use.
2) From the Section Data, select Options > Section Filters.
3) In the Section Filters window, either create a new filter or select a predefined filter. In this case, the WeekFilter was created with the information map and therefore is considered predefined (versus creating it within Web Report Studio). See "Creating Filters and Prompts" on page 5 for details.

![Image of Setting up the Detailed Report](image2.png)

**Figure 17 Setting up the Detailed Report**
SETTING UP THE SUMMARY REPORT

The Summary report can easily be linked to the Detailed report. From the Edit tab, do the following:

1) Select the object where you want to establish the link. Select Report Linking from the pop-up menu.
2) Select the An existing report or stored process radio button and navigate to the report.

In the Tool-top text field, you can add a message to the user.

3) Click the Set Up Destination Report button.
4) Select the section you want to display when the user clicks the object.
5) Select the data item that contains the link.

Figure 18. Setting up the Summary Report

The results are shown in Figure 16.
WORKING WITH THE SAS INFORMATION DELIVERY PORTAL

SAS Information Delivery Portal provides each organization with the flexibility to group, organize, and display the data and reporting in a single location. Using the portal, you can easily combine SAS reports, dashboards, stored process results, information maps, and even other web-based applications in one location. Additionally, any security can also be addressed to ensure the data is safe.

ELEMENTS OF THE PORTAL

The portal contains pages, which then contain portlets. Each tab represents a portal page. The page in the example is called Blog Statistics and it contains four portlets: a collection portlet, two stored process portlets, and a report portlet.

- Collection portlets allow you to add RSS content, such as a link to the BI-Notes.Com blog. There are also portlets that allow you to have the blog link on the page.
- Stored Process portlets allow you to add SAS Stored Processes. You can have more than one portlet type in a page. Each portlet contains the same stored process; the top one has the keyword searches made by new visitors to the site and the bottom one contains the keyword searches from the returning visitors. (These stored processes use the GA_KEYWORDS data set noted in “Getting the Google Analytics Data” on page 1.)
- Report portlets allow you to add a SAS Web Report Studio report. This portlet contains the report we created in the last section.

Figure 19 Overview of Portal Page
ADDING A PORTLET

For this example, you are going to add the Summary Report shown in Figure 19 as 4.

To add a portlet, do the following:

1) From the page you want to modify, select Customize > Edit Page > Edit Page Content.
2) Modify the page layout by changing the columns and column widths, if desired. This page already has three portlets. You want to add a SAS Report portlet to contain the Summary Report.
3) Click the Add Portlets button.
4) In the Add Portlets window, do the following:
   a) Select the Portlet Type of SAS Report Portlet.
   b) Type a portlet name in the Name field.
   c) Add the description and keywords so it can be found during a search.
   d) Click the Add button to add the new portlet.
   e) Click OK to return to the Edit Page Content window.
5) The new portlet defaults to Column 1. Select it and click the right arrow to move it to Column 2.
6) Click OK to return to the portal page.

![Figure 20 Adding a SAS Report Portlet]
ADDING THE WEB REPORT
To add the portlet, click the Edit Properties button 1, navigate to the report 2, and click the OK button 3.

Figure 21 Adding the Report to the Portlet
TIPS & TRICKS: ADDING EXTERNAL CONTENT

Might be cool to add a Twitter feed to your portal page? If you are not familiar with Twitter, users send tweets (SMS-compatible messages) about topics. Topics of interest are prepended a hash tag (#), such as #SAS, #sastip, or #MustBeFriday.

This way the viewer can see the Twitter content related to the search criteria immediately on the page. Do the following:

1) Edit the portal page and add a new URL portlet.

2) After you add the URL portlet, edit the properties to add the URL with the hash tag string. Use the ATOM feed to search for the #SASBIBook hashtag, so you know when the topic is discussed.

   http://search.twitter.com/search.atom?q=%23SASBIBook

   Note: The %23 is the URL-encoding symbol for the hash tag (#) symbol. You can append other parameters to the URL string, such as &rpp=5 to retrieve the last 5 posts. Check the Twitter API documentation for more options.

3) Check your results!

CONCLUSION

Analysis becomes a snap even with data that seems completely out of reach, such as Google Analytics, using the SAS BI toolset.

In addition, we have only scratched the surface of all the tasks this tool is capable of completing. Check out the Building Business Intelligence with SAS: Content Development Examples book for additional tips and tricks for all of the SAS BI tools!
REFERENCES

- Aanderud, T, Business Intelligence Notes for SAS® BI Users. Available at http://www.bi-notes.com
- Hall, A. Real BI for Real Users. Available at http://blogs.sas.com/content/bi

ACKNOWLEDGMENTS

These products are used or discussed in this paper:

- Excellent Analytics - available at http://excellentanalytics.com/
- Google Analytics - available at http://www.google.com/analytics/
- Google Analytics for Wordpress Plug-In - available at http://yoast.com/wordpress/

RECOMMENDED READING


CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the authors at:

    Tricia Aanderud, And Data, Inc., tricia.aanderud@gmail.com
    Angela Hall, SAS Institute, Inc., angela.hall@sas.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.